Aspectos a tener en cuenta a la hora de seleccionar hosting para alojar Moodle

En primer lugar deberé tener claro qué versión de Moodle voy a instalar y cuales son sus requisitos previos de infraestructura, algo que cada versión de Moodle refleja en su documentación técnica. En este aspecto, deberemos tener en cuenta que nuestro proveedor de hosting soporte las versiones de PHP, Apache y MySQL mínimas requeridas por la versión de Moodle a implementar. El mayor problema actual es que aún hay proveedores de hosting que no han migrado la versión de PHP 5.3.2 o superior requerida por Moodle 2.x .
  • Quedan por lo tanto descartados aquellos proveedores que no tengan LAMP como uno de los estándar de su infraestructura (Linux, Apache, MySQL y PHP). Es posible instalar Moodle sobre Windows, (en este blog se ha hablado mucho de ello) pero el rendimiento, a igualdad de condiciones, es siempre superior en Linux.
  • Quedan descartados aquellos proveedores que no garanticen las versiones correctas de LAMP y que no se comprometan a actualizar razonablemente estas según progresen los requerimientos de Moodle en el futuro.